Ashburn (IAD) Maintenance
Maintenance
in progress
5 hours 5 minutes
21 September 2026, 17:30 UTC
Ashburn (IAD) Maintenance
Status: in progress
Start:
21 September 2026, 17:30 UTC
Estimated Duration: 1440 minutes
Affected Components:
Platform
North America
Ashburn (IAD)
Update
21 September 2026, 17:30 UTC
21 September 2026, 17:30 UTC
Fastly will be performing scheduled maintenance on our Ashburn (IAD) data center from 21 September 2026, 17:30 UTC - 22 September 2026, 17:30 UTC.
During this time frame traffic will be redirected to neighboring sites within the Ashburn (IAD) data center or from POPs within the region.