Retrospective: Impacted Performance in Log Explorer & Insights

Informational
12 September 2026, 22:29 UTC

Retrospective: Impacted Performance in Log Explorer & Insights

Status: closed
Date: 12 September 2026, 20:52 UTC
End: 12 September 2026, 22:29 UTC
Duration: 1 hour 37 minutes
Affected Components:
Observability Log Explorer & Insights Real-time Log Streaming
Monitoring

12 September 2026, 20:52 UTC

12 September 2026, 20:52 UTC

Fastly Engineers detected a performance impacting event affecting our Real-time Log Streaming and Log Explorer & Insights data.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

12 September 2026, 22:29 UTC

12 September 2026, 22:29 UTC

During this incident, customers using logging globally may have experienced delayed or dropped log data, along with elevated errors and increased latency concentrated in our US-West region, from 20:52 to 21:23 UTC and again from 22:16 to 22:29 UTC. The vast majority of logs were delivered successfully throughout this period.

For more information about this retrospective stat us post, please reach out to Support through https://support.fastly.com .