Elevated Errors for Compute

Incident
09 September 2026, 22:05 UTC

Elevated Errors for Compute

Status: closed
Start: 09 September 2026, 18:28 UTC
End: 09 September 2026, 22:05 UTC
Duration: 3 hours 37 minutes
Affected Components:
Compute Fanout Fastly Compute AI Accelerator Edge Cloud Services Websockets Config Store KV Store Secret Store
Investigating

09 September 2026, 18:28 UTC

09 September 2026, 18:28 UTC

We are investigating an issue causing elevated 5xx errors for some customers using our Compute services.

Our engineers are actively working to diagnose the contributing factor.  We will provide another update as more information becomes available or within the next hour.


All other products and services are unaffected by this incident.

Identified

09 September 2026, 19:20 UTC

09 September 2026, 19:20 UTC

Our engineers believe they have identified the contributing factor causing the issue impacting our Compute services.

Our engineers are now developing a fix, and we will post a new update once it has been fully implemented and we see signs of recovery.

All other products and services remain unaffected by this incident.

Monitoring

09 September 2026, 20:33 UTC

09 September 2026, 20:33 UTC

Engineering has deployed a fix and have confirmed a gradual recovery to Compute services. We will continue to monitor until we’ve confirmed that customer experience has been fully restored.

All other products and services remain unaffected by this incident.



Resolved

09 September 2026, 22:05 UTC

09 September 2026, 22:05 UTC

Engineering has confirmed that Compute services has been fully restored. Customers may have experienced elevated 5xx errors from 18:28 to 21:52 UTC.

This incident is resolved.



Note:  Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.

Status Post, Created Date/Time:   2026-09-09 19:15:48 UTC