Update to waitlist disconnect response codes
Update to waitlist disconnect response codes
02 September 2026, 17:05 UTC
02 September 2026, 17:05 UTC
Fastly is updating how a subset of client disconnects are reported for Delivery (Varnish) Services. Previously, these disconnects returned a 503 (Service Unavailable) response code. As part of a fix for an issue affecting our
ERROR-WAIT
handling, we changed this behavior so a subset of these disconnects now return a 499 (Client Closed Request) and will have an
ERROR-DISCONNECT
state.
This change will be rolling out gradually over the next few weeks.
What you may notice:
You may see an increase in 499 response codes and a corresponding decrease in 503 response codes for waitlist disconnects in your logs and dashboards. This is expected and does not indicate a new issue with your service.
What you need to do:
If you have monitoring, alerting, or automation that treats 503s and 499s differently, review your configuration to confirm it accounts for this change. If you have questions, contact your Fastly support team.