Impacted performance to our Content Delivery (CDN)

Incident
21 August 2026, 10:19 UTC

Impacted performance to our Content Delivery (CDN)

Status: in progress
Start: 20 August 2026, 22:33 UTC
Affected Components:
Network Services Content Delivery (CDN)
Investigating

20 August 2026, 22:33 UTC

20 August 2026, 22:33 UTC

We are investigating a small number of requests receiving an empty response body where content is expected. Impact is limited to requests that use Streaming Miss and are eligible for HTTP response revalidation.

All other products and services are unaffected by this incident.

Identified

20 August 2026, 23:32 UTC

20 August 2026, 23:32 UTC

Our engineers believe they have identified contributing factor causing the issue impacting the Content Delivery (CDN) status page component.

We are now developing a fix, and will post a new update once it has been fully implemented and we see signs of recovery.

All other products and services are unaffected by this incident.

Identified

21 August 2026, 00:33 UTC

21 August 2026, 00:33 UTC

Our engineers have identified an additional contributing factor and are developing an adjusted mitigation strategy to our Content Delivery (CDN) service.

All other locations and services are unaffected.

Monitoring

21 August 2026, 10:19 UTC

21 August 2026, 10:19 UTC

Engineering has confirmed the impact to our Content Delivery (CDN) service has been mitigated.