Reduced cache performance for Compute services

Incident
20 August 2026, 23:09 UTC

Reduced cache performance for Compute services

Status: closed
Start: 20 August 2026, 06:21 UTC
End: 20 August 2026, 23:09 UTC
Duration: 16 hours 48 minutes
Affected Components:
Compute Edge Cloud Services
Identified

20 August 2026, 06:21 UTC

20 August 2026, 06:21 UTC

Our engineers have identified a contributing factor causing reduced cache-hit performance for a subset of cache infrastructure serving Compute customers. Affected customers may see temporarily elevated origin load.

A fix is being deployed to the affected nodes. Due to the scope of the change, full deployment will take some time. We will post updates as the rollout progresses.

All other products and services remain unaffected by this incident.

Monitoring

20 August 2026, 08:12 UTC

20 August 2026, 08:12 UTC

We have identified the cause of reduced cache-hit ratio and elevated origin load affecting a subset of Compute customers using caching, and have deployed a fix.

The fix is being rolled out gradually across affected sites and cache nodes, timed to off-peak windows to minimize any additional disruption. Some locations have already completed the rollout; others remain in progress.

We are actively monitoring recovery and will provide another update as the rollout completes.

Resolved

20 August 2026, 23:09 UTC

20 August 2026, 23:09 UTC

We're updating this incident with corrected details following further investigation. The actual impact was delayed purge processing for a subset of sites, caused by slower purge handling in our object caching software introduced in a recent release — not a broader Edge Cloud Service issue as previously described.

This resulted in an elevated purge backlog and, for affected sites, previously cached content could be served longer than expected until the backlog cleared.

This incident is resolved.