Retrospective: Impacted Performance in Frankfurt (FRA), Ashburn (IAD), Object Storage

Informational
10 August 2026, 20:09 UTC

Retrospective: Impacted Performance in Frankfurt (FRA), Ashburn (IAD), Object Storage

Status: closed
Date: 10 August 2026, 19:50 UTC
End: 10 August 2026, 20:09 UTC
Duration: 19 minutes
Affected Components:
Network Services Platform North America Europe Object Storage Ashburn (IAD) Frankfurt (FRA)
Update

10 August 2026, 19:50 UTC

10 August 2026, 19:50 UTC

We have identified an issue that caused elevated error rates (HTTP 429/503) and timeouts for Object Storage in the Frankfurt (FRA), Ashburn (IAD) Points of Presence (POP)s.

All other products and services are unaffected by this incident.

Resolved

10 August 2026, 20:09 UTC

10 August 2026, 20:09 UTC

This incident has been resolved.