Retrospective: Fastly Control Panel and API Performance Issues

Informational
26 June 2026, 07:19 UTC

Retrospective: Fastly Control Panel and API Performance Issues

Status: closed
Date: 26 June 2026, 06:05 UTC
End: 26 June 2026, 07:19 UTC
Duration: 1 hour 14 minutes
Affected Components:
Fastly Fastly Control Panel API & Configuration Management API Services Configuration Management Services
Update

26 June 2026, 06:05 UTC

26 June 2026, 06:05 UTC

Fastly Engineers detected a performance impacting event affecting the availability of manage.fastly.com and API.

CDN delivery, stats aggregation, and all other data plane services were unaffected.

The issue has been resolved and we are monitoring performance closely.

Resolved

26 June 2026, 07:19 UTC

26 June 2026, 07:19 UTC

This event has been resolved.