Retrospective: Impacted Performance in Hong Kong (HKG)

Informational
11 June 2026, 16:01 UTC

Retrospective: Impacted Performance in Hong Kong (HKG)

Status: closed
Date: 11 June 2026, 15:01 UTC
End: 11 June 2026, 16:01 UTC
Duration: 1 hour
Affected Components:
Platform Asia Hong Kong (HKG)
Monitoring

11 June 2026, 15:01 UTC

11 June 2026, 15:01 UTC

Fastly Engineers detected a performance impacting event affecting the Hong Kong (HKG) data center.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Monitoring

11 June 2026, 15:59 UTC

11 June 2026, 15:59 UTC

Our Engineers have deployed standard mitigations for this impact and continue to monitor our Hong Kong (HKG) performance trends. We will provide an update once the HKG POP has been fully restored. Customers may continue to experience elevated or intermittent errors as the POP recovers.

Resolved

11 June 2026, 16:01 UTC

11 June 2026, 16:01 UTC

This event has been resolved.