Houston (IAH) Rerouted Traffic

Informational
04 June 2026, 09:25 UTC

Houston (IAH) Rerouted Traffic

Status: closed
Date: 04 June 2026, 08:00 UTC
End: 04 June 2026, 09:25 UTC
Duration: 1 hour 25 minutes
Affected Components:
Platform North America Houston (IAH)
Update

04 June 2026, 08:00 UTC

04 June 2026, 08:00 UTC

Traffic in Houston (IAH) has been temporarily rerouted.

All other locations and services are unaffected.

Resolved

04 June 2026, 09:25 UTC

04 June 2026, 09:25 UTC

This event has been resolved.