Retrospective: Impacted Performance in Ashburn (IAD)

Informational
21 May 2026, 21:35 UTC

Retrospective: Impacted Performance in Ashburn (IAD)

Status: closed
Date: 21 May 2026, 21:29 UTC
End: 21 May 2026, 21:35 UTC
Duration: 6 minutes
Affected Components:
Platform North America Ashburn (IAD)
Monitoring

21 May 2026, 21:29 UTC

21 May 2026, 21:29 UTC

Fastly Engineers detected a performance impacting event affecting the Ashburn (IAD) data center.

Resolved

21 May 2026, 21:35 UTC

21 May 2026, 21:35 UTC

The issue causing temporary unhealthy cache nodes was resolved, and services were fully restored.

Our engineers confirmed that all cache nodes returned to a healthy state. Customers may have experienced impact between 21:29 UTC and 21:35 UTC (approximately 6 minutes).

All other services and locations were unaffected by this event.