Retrospective: Impacted Performance in TLS Provisioning

Informational
12 May 2026, 13:59 UTC

Retrospective: Impacted Performance in TLS Provisioning

Status: closed
Date: 12 May 2026, 13:49 UTC
End: 12 May 2026, 13:59 UTC
Duration: 10 minutes
Affected Components:
Network Services Domain Management TLS Provisioning
Monitoring

12 May 2026, 13:49 UTC

12 May 2026, 13:49 UTC

Fastly Engineers detected a performance impacting event affecting the TLS Provisioning service.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

12 May 2026, 13:59 UTC

12 May 2026, 13:59 UTC

This event has been resolved.