Retrospective: Impacted Performance in API & Configuration Management

Informational
24 April 2026, 18:20 UTC

Retrospective: Impacted Performance in API & Configuration Management

Status: closed
Date: 24 April 2026, 18:07 UTC
End: 24 April 2026, 18:20 UTC
Duration: 13 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management API Services Configuration Management Services
Monitoring

24 April 2026, 18:07 UTC

24 April 2026, 18:07 UTC

Fastly Engineers detected a performance impacting event affecting our API & Configuration Management service.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

24 April 2026, 18:20 UTC

24 April 2026, 18:20 UTC

During this incident, customers may have experienced delayed VCL deployment activations from 18:07 to 18:20 UTC.

This incident is resolved.

For more information about this retrospective status post, please reach out to Support through https://support.fastly.com.