Retrospective: Fastly Application and API Performance Issues

Informational
22 April 2026, 07:15 UTC

Retrospective: Fastly Application and API Performance Issues

Status: closed
Date: 22 April 2026, 06:07 UTC
End: 22 April 2026, 07:15 UTC
Duration: 1 hour 8 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management API Services Configuration Management Services
Update

22 April 2026, 06:07 UTC

22 April 2026, 06:07 UTC

Fastly Engineers detected a performance impacting event affecting the availability of manage.fastly.com and API.

CDN delivery, stats aggregation, and all other data plane services were unaffected.

Resolved

22 April 2026, 07:15 UTC

22 April 2026, 07:15 UTC

Engineering has confirmed that API & Configuration Management service has been fully restored. Customers may have experienced issues using API services and accessing manage.fastly.com from 06:07 to 07:15 UTC.

This incident is resolved.

Affected customers may have experienced impact to varying degrees and to a shorter duration than as set forth above.



Note:  Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.

Status Post, Created Date/Time:   2026-04-22 07:35:20 UTC