Retrospective: Impacted Performance in Fastly Application

Informational
21 April 2026, 17:35 UTC

Retrospective: Impacted Performance in Fastly Application

Status: closed
Date: 21 April 2026, 17:30 UTC
End: 21 April 2026, 17:35 UTC
Duration: 5 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management Notification Center API Services Configuration Management Services
Monitoring

21 April 2026, 17:30 UTC

21 April 2026, 17:30 UTC

Fastly Engineers detected a performance impacting event affecting the Fastly Application. 

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

21 April 2026, 17:35 UTC

21 April 2026, 17:35 UTC

During this incident, customers may have experienced the inability to access their Fastly Application and it's sub-services from 17:30 to 17:35 UTC.

This incident is resolved.

For more information about this retrospective status post, please reach out to Support through https://support.fastly.com.