Elevated Errors for Fastly Application

Incident
21 April 2026, 16:32 UTC

Elevated Errors for Fastly Application

Status: closed
Start: 21 April 2026, 14:05 UTC
End: 21 April 2026, 16:32 UTC
Duration: 2 hours 27 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management Notification Center API Services Configuration Management Services
Investigating

21 April 2026, 14:05 UTC

21 April 2026, 14:05 UTC

We are investigating elevated errors when attempting to log into our Fastly Application user interface and sub-services.

All other products and services are unaffected by this incident.

Identified

21 April 2026, 14:49 UTC

21 April 2026, 14:49 UTC

Our engineers believe they have identified contributing factor causing the issue impacting the ability to access our Fastly Application and it's sub-service components.

We are now developing a fix, and will post a new update once it has been fully implemented and we see signs of recovery.

All other products and services are unaffected by this incident.

Monitoring

21 April 2026, 14:50 UTC

21 April 2026, 14:50 UTC

Engineering has confirmed the impact to Fastly Application and it's sub-services has been mitigated.

Monitoring

21 April 2026, 15:03 UTC

21 April 2026, 15:03 UTC

Engineering is seeing a gradual recovery to our customer's ability to access their Fastly Application services. We believe that customers may see intermittent errors as we continue to fine tune our mitigation strategy further. We will continue to monitor until we’ve confirmed that customer experience has been fully restored.

Our ability to deliver network and security services were unaffected by this incident.



Resolved

21 April 2026, 16:32 UTC

21 April 2026, 16:32 UTC

Engineering has confirmed that Fastly Application service has been fully restored. Customers may have experienced the inability to access their Fastly Application and it's sub-services from 14:05 to 15:53 UTC.

This incident is resolved.

Affected customers may have experienced impact to varying degrees and to a shorter duration than as set forth above.



Note:  Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.

Status Post, Created Date/Time:   2026-04-21 14:30:05 UTC