Elevated Errors for Ashburn (IAD)

Incident
20 April 2026, 22:47 UTC

Elevated Errors for Ashburn (IAD)

Status: closed
Start: 20 April 2026, 15:55 UTC
End: 20 April 2026, 22:47 UTC
Duration: 6 hours 52 minutes
Affected Components:
Platform North America Ashburn (IAD)
Identified

20 April 2026, 15:55 UTC

20 April 2026, 15:55 UTC

We are investigating elevated errors to our Ashburn (IAD).

All other products and services are unaffected by this incident.

Monitoring

20 April 2026, 22:33 UTC

20 April 2026, 22:33 UTC

Engineering has confirmed the impact to Ashburn (IAD) PoP has been mitigated.

Resolved

20 April 2026, 22:47 UTC

20 April 2026, 22:47 UTC

Our engineers have confirmed that traffic routing through our Ashburn (IAD) POP has been fully restored. Because a software defect caused brief node crashes, customers routing traffic through the affected nodes may have experienced a temporary increase in 5xx errors and dropped connections from 15:55 to 22:10 UTC on April 20, 2026.

This incident is resolved.

Affected customers may have experienced impact to varying degrees and to a shorter duration than as set forth above.