Retrospective: Impacted Performance for API Services

Informational
17 April 2026, 12:55 UTC

Retrospective: Impacted Performance for API Services

Status: closed
Date: 17 April 2026, 12:40 UTC
End: 17 April 2026, 12:55 UTC
Duration: 15 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management API Services
Monitoring

17 April 2026, 12:40 UTC

17 April 2026, 12:40 UTC

Fastly Engineers detected a performance impacting event affecting our API Services.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

17 April 2026, 12:55 UTC

17 April 2026, 12:55 UTC

During this incident, customers may have experienced high API latency, high API service error rates and slow loading or errors when attempting to access manage.fastly.com from 12:40 to 12:55 UTC.

This incident is resolved.

For more information about this retrospective status post, please reach out to Support through https://support.fastly.com.