Houston (IAH) Rerouted Traffic
Informational
17 March 2026, 11:45 UTC
Houston (IAH) Rerouted Traffic
Status: closed
Date:
17 March 2026, 08:10 UTC
End:
17 March 2026, 11:45 UTC
Duration: 3 hours 35 minutes
Affected Components:
Platform
North America
Houston (IAH)
Update
17 March 2026, 08:10 UTC
17 March 2026, 08:10 UTC
Traffic in Houston (IAH) has been temporarily rerouted.
All other locations and services are unaffected.
Resolved
17 March 2026, 11:45 UTC
17 March 2026, 11:45 UTC
This event has been resolved.