Notification Service API with Possible Impact

Incident
16 March 2026, 23:24 UTC

Notification Service API with Possible Impact

Status: closed
Start: 16 March 2026, 21:25 UTC
End: 16 March 2026, 23:24 UTC
Duration: 1 hour 59 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management API Services
Investigating

16 March 2026, 21:25 UTC

16 March 2026, 21:25 UTC

We're investigating possible performance impact affecting the Notification Service API integration of our API Services. 

All other services are unaffected.

Identified

16 March 2026, 22:42 UTC

16 March 2026, 22:42 UTC

Our engineers believe they have identified contributing factor causing the issue impacting the Notification Service API status page component.

We are now developing a fix, and will post a new update once it has been fully implemented and we see signs of recovery.

All other products and services are unaffected by this incident.

Monitoring

16 March 2026, 23:08 UTC

16 March 2026, 23:08 UTC

Engineering has confirmed the impact to Notification Service API integrations has been mitigated.

Resolved

16 March 2026, 23:24 UTC

16 March 2026, 23:24 UTC

Engineering has confirmed that the Notification Service API integration has been fully restored.  Between 21:25 and 22:51 UTC, customers may have experienced failed or delayed notification deliveries and elevated errors when attempting to create, read, update, or delete new and existing notification integrations.

This incident is resolved.



Note:   Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.

Status Post, Created Date/Time:    2026-03-16 22:42:24 UTC