Upcoming Maintenance for Fastly Support Portal

Maintenance
18 March 2026, 18:00 UTC

Upcoming Maintenance for Fastly Support Portal

Status: closed
Start: 18 March 2026, 14:00 UTC
End: 18 March 2026, 18:00 UTC
Duration: 4 hours
Affected Components:
Fastly Customer Services Support Systems https://support.fastly.com New Support Case
Update

18 March 2026, 14:00 UTC

18 March 2026, 14:00 UTC

Fastly will be performing scheduled maintenance on the Fastly Support portal on March 18, 2026, from 14:00 to 18:00 UTC (240 minutes).

What to expect

During this 4-hour window, the Support Portal will be offline. Attempting to log in during this time will result in an error.

  • No action is required on your part. This maintenance is fully managed by our team.

How to reach support

While the portal is down, our Support team remains fully staffed and available. We do not anticipate any negative impact on our support response times or SLAs.

If you need assistance during the maintenance window, please use our alternative channels:

  • Email: support@fastly.com 

  • Chat: Available through your standard Support Chat channels.

  • Community: Visit our Fastly Community for answers to common questions and the latest updates.

Resolved

18 March 2026, 18:00 UTC

18 March 2026, 18:00 UTC

The scheduled maintenance has been completed.

To offer feedback on our status page, click "Give Feedback