Houston (IAH) Rerouted Traffic

Informational
24 February 2026, 11:23 UTC

Houston (IAH) Rerouted Traffic

Status: closed
Date: 24 February 2026, 07:24 UTC
End: 24 February 2026, 11:23 UTC
Duration: 3 hours 59 minutes
Affected Components:
Platform North America Houston (IAH)
Update

24 February 2026, 07:24 UTC

24 February 2026, 07:24 UTC

Traffic in Houston (IAH) has been temporarily rerouted.

All other locations and services are unaffected.

Resolved

24 February 2026, 11:23 UTC

24 February 2026, 11:23 UTC

This event has been resolved.