New Data Centers, Asansol (QAW) and Noida (QBD)

Maintenance
29 January 2026, 22:00 UTC

New Data Centers, Asansol (QAW) and Noida (QBD)

Status: closed
Start: 29 January 2026, 18:00 UTC
End: 29 January 2026, 22:00 UTC
Duration: 4 hours
Affected Components:
Platform Asia Asansol (QAW) Noida (QBD)
Update

29 January 2026, 18:00 UTC

29 January 2026, 18:00 UTC

As part of Fastly’s global network expansion, we will be adding two new data centers, Asansol (QAW) and Noida (QBD) to Fastly's Asia network.

Traffic served by our Asansol (QAW) and  Noida (QBD) data centers will be aggregated into our Asia  region for billing and stats purposes.

We expect that some traffic currently served by our data centers in neighboring regions will shift to  these new Points of Presence (POPs) . As such, some customers may see a change in their bills.

Fastly’s standard billing rates are located at https://www.fastly.com/pricing.

Resolved

29 January 2026, 22:00 UTC

29 January 2026, 22:00 UTC

The scheduled maintenance has been completed.