Retrospective: Impacted Performance in Signals Dashboard

Informational
23 January 2026, 18:36 UTC

Retrospective: Impacted Performance in Signals Dashboard

Status: closed
Date: 23 January 2026, 18:13 UTC
End: 23 January 2026, 18:36 UTC
Duration: 23 minutes
Affected Components:
Security Security Console & API Signals Dashboard
Monitoring

23 January 2026, 18:13 UTC

23 January 2026, 18:13 UTC

Fastly Engineers detected a recurrence of a performance impacting event affecting the Signals Dashboard service.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

23 January 2026, 18:36 UTC

23 January 2026, 18:36 UTC

This event has been resolved.