Retrospective: Impacted Performance in API Services

Informational
15 January 2026, 01:31 UTC

Retrospective: Impacted Performance in API Services

Status: closed
Date: 14 January 2026, 18:15 UTC
End: 15 January 2026, 01:31 UTC
Duration: 7 hours 16 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management API Services
Affected Groups:
All Public Users
Monitoring

14 January 2026, 18:15 UTC

14 January 2026, 18:15 UTC

Fastly Engineers detected a performance impacting event affecting our API Services.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

15 January 2026, 01:31 UTC

15 January 2026, 01:31 UTC

During this incident, customers may have experienced false positive email notifications incorrectly stating that API tokens were being used from new IP addresses from 18:15 UTC on the 14th of January 2026 to 01:31 UTC on the 15th of January 2026.

This incident is resolved.

For more information about this retrospective status post, please reach out to Support through https://support.fastly.com.