Possible Impact to Support Chat Services Caused by a Third Party Service Provider

Informational
10 November 2025, 20:33 UTC

Possible Impact to Support Chat Services Caused by a Third Party Service Provider

Status: closed
Date: 10 November 2025, 18:31 UTC
End: 10 November 2025, 20:33 UTC
Duration: 2 hours 2 minutes
Affected Components:
Fastly Customer Services Third Party Service Provider Support Systems Support Chat System
Affected Groups:
All Public Users
Update

10 November 2025, 18:31 UTC

10 November 2025, 18:31 UTC

We are seeing a possible error or delay in message propagation within our Support Chat Systems, caused by a third party service provider issue. The provider has shared information on their status page.

Our ability to provide support through support@fastly.com is unaffected by this incident, if you are experiencing delayed responses in your dedicated support chat channel, please switch to email methods to ensure prompt response by our support team. Network and Security products remain unaffected by this third party provider event, and services continue to be delivered to our customers.

We will continue to monitor the providers status page and report once Support Chat Systems are no longer at risk of impact.

Resolved

10 November 2025, 20:33 UTC

10 November 2025, 20:33 UTC

Our third party service provider has confirmed that mitigations have been deployed and all Support Chat Services have been fully restored. 

Our ability to deliver all other services were unaffected by the third party providers incident.


To offer feedback on our status page, click "Give Feedback" 

Status Post, Created Date/Time: 2025-11-10 18:33:02 UTC