Retrospective: Impacted Performance to Fastly-managed certificates

Informational
07 October 2025, 16:18 UTC

Retrospective: Impacted Performance to Fastly-managed certificates

Status: closed
Date: 07 October 2025, 00:30 UTC
End: 07 October 2025, 16:18 UTC
Duration: 15 hours 48 minutes
Affected Components:
Network Services Domain Management TLS Encryption TLS Provisioning Origin Connect
Affected Groups:
All Public Users
Monitoring

07 October 2025, 00:30 UTC

07 October 2025, 00:30 UTC

Fastly Engineers detected a performance impacting event affecting our certificate authorization system for Fastly-managed certificates.

All other data centers and services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

07 October 2025, 16:18 UTC

07 October 2025, 16:18 UTC

During this incident, customers may have experienced inability to issue Fastly-managed certificates from 00:30 to 16:18 UTC. Existing Fastly-managed certificates were unaffected by this incident. 

This incident is resolved.

For more information about this retrospective status post, please reach out to Support through https://support.fastly.com.