Possible Increase to Origin for Custom VCL Using querystring API

Incident
09 October 2025, 13:16 UTC

Possible Increase to Origin for Custom VCL Using querystring API

Status: closed
Start: 07 October 2025, 16:31 UTC
End: 09 October 2025, 13:16 UTC
Duration: 1 day 20 hours 45 minutes
Affected Components:
Network Services Content Delivery (CDN)
Affected Groups:
All Public Users
Investigating

07 October 2025, 16:31 UTC

07 October 2025, 16:31 UTC

We're investigating possible performance impact affecting the Content Delivery (CDN) data center.

All other locations and services are unaffected.

Identified

07 October 2025, 16:49 UTC

07 October 2025, 16:49 UTC

We have identified an issue with how our systems are processing requests that involve setting querystring parameters from custom VCL using the querystring API. This is causing an increase to origin for requests that have querystring parameters with an empty value.

We are now developing a fix, and will post a new update once it has been fully implemented and we see signs of recovery.

All other products and services are unaffected by this incident.

Monitoring

07 October 2025, 17:20 UTC

07 October 2025, 17:20 UTC

Engineering has deployed a fix and have confirmed a gradual recovery for customers with a custom VCL using the querystring API. We will continue to monitor until we’ve confirmed that customer experience has been fully restored. 

As this mitigation deploys throughout our fleet, customers who believe their services to be impacted may reach out to our Support team by emailing support@fastly.com. Our team has been provided with workaround that will can be deployed to prevent impact for the duration of our response to this event.

All other products and services remain unaffected by this incident.


Resolved

09 October 2025, 13:16 UTC

09 October 2025, 13:16 UTC

Our engineering team deployed a fleet-wide mitigation strategy to correct the issue. Customers confirmed to be impacted by this incident and who implemented the temporary mitigation measures provided on October 7th were not affected after that point.

For all other affected customers, the issue was fully resolved by 09:45 UTC on October 9th.

To offer feedback on our status page, click "Give Feedback" 

Status Post, Created Date/Time: 2025-10-07 16:33:08 UTC 



Note: Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.