Retrospective: Impacted Performance in API & Configuration Management

Informational
07 October 2025, 15:30 UTC

Retrospective: Impacted Performance in API & Configuration Management

Status: closed
Date: 07 October 2025, 14:52 UTC
End: 07 October 2025, 15:30 UTC
Duration: 38 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management API Services Configuration Management Services
Affected Groups:
All Public Users
Update

07 October 2025, 14:52 UTC

07 October 2025, 14:52 UTC

Fastly Engineers detected a performance impacting event affecting the API & Configuration Management 

The issue has been resolved and we are monitoring performance closely.

Resolved

07 October 2025, 15:30 UTC

07 October 2025, 15:30 UTC

During this incident, customers may have experienced issues with service activation and dictionary changes from 14:52 to 15:30 UTC.

This incident is resolved, and all services are operating normally.

For more information about this retrospective status post, please reach out to Support through https://support.fastly.com .