Upcoming Changes to Fastly Network Management Services

Maintenance
30 September 2025, 18:00 UTC

Upcoming Changes to Fastly Network Management Services

Status: closed
Start: 30 September 2025, 17:00 UTC
End: 30 September 2025, 18:00 UTC
Duration: 1 hour
Affected Components:
Network Services Content Delivery (CDN)
Affected Groups:
All Public Users
Update

30 September 2025, 17:00 UTC

30 September 2025, 17:00 UTC

As a part of our continued effort to enhance network efficiency across our platform, Fastly will be performing maintenance on our network management services beginning on Monday, the 30th of September 2025 at 17:00 UTC.

Our estimated duration is 60 minutes.

What’s Changing?

We will be deploying new updates to our network access control management system. This change will allow our backend systems that handle internal traffic management to communicate more efficiently and securely. During this maintenance, customers can expect minimal disruption to the Fastly Control Panel or API as these changes are being deployed.

All other services remain unaffected by this maintenance.

What’s next? What do I have to do?

Nothing. All actions taken during this planned maintenance belong to Fastly.

Customers with any questions or concerns may engage with our Support team through https://support.fastly.com or by contacting your designated account management team members.

Resolved

30 September 2025, 18:00 UTC

30 September 2025, 18:00 UTC

The scheduled maintenance has been completed.

To offer feedback on our status page, click "Give Feedback