Elevated Errors for Log Explorer & Insights

Incident
25 September 2025, 00:28 UTC

Elevated Errors for Log Explorer & Insights

Status: closed
Start: 24 September 2025, 19:40 UTC
End: 25 September 2025, 00:28 UTC
Duration: 4 hours 48 minutes
Affected Components:
Observability Log Explorer & Insights
Affected Groups:
All Public Users
Investigating

24 September 2025, 19:40 UTC

24 September 2025, 19:40 UTC

We are investigating elevated errors to our Log Explorer & Insights service. 

All other products and services are unaffected by this incident.

Identified

24 September 2025, 19:42 UTC

24 September 2025, 19:42 UTC

Our engineers have identified the contributing factor and are developing a fix to our Log Explorer & Insights service.

All other locations and services are unaffected.

Identified

24 September 2025, 20:42 UTC

24 September 2025, 20:42 UTC

Our engineers have identified a different contributing factor and are developing an adjusted mitigation strategy to our Log Explorer & Insights service.

All other locations and services are unaffected.

Monitoring

24 September 2025, 23:30 UTC

24 September 2025, 23:30 UTC

Engineering has deployed a fix and we are observing a gradual restoration of our Log Explorer & Insights service, though some customers may continue to experience intermittent issues as the system stabilizes. Our team is actively monitoring the recovery and will post another update once services are fully restored.

Network availability and all other services were unaffected by this incident.

Resolved

25 September 2025, 00:28 UTC

25 September 2025, 00:28 UTC

Engineering has confirmed that Log Explorer & Insights service has been fully restored. Customers may have experienced elevated errors from 24 September at 18:30 UTC to 25 September at 00:28 UTC.

This incident is resolved.

To offer feedback on our status page, click "Give Feedback

Status Post, Created Date/Time: 2025-09-24 19:42:05 UTC 



Note: Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.