Performance Impact Issuing TLS Certificates with a Third Party Service Provider

Incident
10 September 2025, 21:31 UTC

Performance Impact Issuing TLS Certificates with a Third Party Service Provider

Status: in progress
Start: 10 September 2025, 19:50 UTC
Affected Components:
Fastly Third Party Service Provider
Affected Groups:
All Public Users
Update

10 September 2025, 19:50 UTC

10 September 2025, 19:50 UTC

Fastly Engineering has identified a performance impact with issuing TLS certificates through one of our third-party service providers that is currently experiencing an outage. 

Customers may experience a failure obtaining a TLS certificate as a result of this outage. Customers who need assistance with obtaining a TLS certificate can engage with our Support team through https://support.fastly.com  We apologize for this inconvenience and remain readily available to resolve any impact experienced as a result of this event.

Update

10 September 2025, 21:31 UTC

10 September 2025, 21:31 UTC

Our Engineering team has confirmed an issue with our third-party provider, Globalsign, which is impacting Fastly-managed subscriptions.

As a result, the addition of new domains is currently blocked for both brand new subscriptions and modifications to existing ones.

No other services are impacted.