Updates to the VCL Editor in the Fastly Control Panel
Updates to the VCL Editor in the Fastly Control Panel
26 August 2025, 18:34 UTC
26 August 2025, 18:34 UTC
On the 26th of August 2025, we released an update to the VCL Editor in the Fastly Control Panel. This release unified Snippets, Custom VCL, and Complete VCL into a single, modernized view. This update introduced several improvements: Modernized Code Editor: Enjoy a smoother coding experience with syntax highlighting, error checking, and code folding. Full-Screen Mode: Expand the editor to easily read, edit, and review complex VCL. Unified VCL View: Manage VCL Snippets, Custom VCL, and Complete VCL in one place to simplify your workflow. Editable Dynamic Snippets: Add and edit Dynamic Snippets directly in the UI. Boilerplate Insertion: Insert boilerplate code directly from the Custom VCL view. Auto-Generated Code: Reduce manual effort by automatically generating standard VCL functions and variables. To learn more about these changes, please see our documentation: About VCL snippets and Using VCL snippets. No action is required. What has Changed
What’s next? What do I have to do?
Contact Information
If you have any questions, please contact our Support team at https://support.fastly.com or reach out to your account team.
26 August 2025, 22:34 UTC
26 August 2025, 22:34 UTC
This event has been resolved.
To offer feedback on our status page, click "Give Feedback"
Status Post, Created Date/Time: 0001-01-01 00:00:00 UTC
Note: Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.