Elevated Errors for Dashboard Data, Data Services

Incident
26 August 2025, 21:56 UTC

Elevated Errors for Dashboard Data, Data Services

Status: closed
Start: 26 August 2025, 17:25 UTC
End: 26 August 2025, 21:56 UTC
Duration: 4 hours 31 minutes
Affected Components:
Security Security Console & API Data Services Dashboard Data
Affected Groups:
All Public Users
Investigating

26 August 2025, 17:25 UTC

26 August 2025, 17:25 UTC

We are investigating elevated errors to our security product Dashboard Data and Data Services. The impact is limited to data propagation within the customer control panel; customers may see delays when making configuration changes. The enforcement of customer Next-Gen WAF (NGWAF) rulesets is not affected. Our engineers are actively investigating.

All other products and services are unaffected by this incident.

Monitoring

26 August 2025, 17:38 UTC

26 August 2025, 17:38 UTC

Recovery is in progress for Dashboard Data and Data Services. Our engineering team has mitigated the issue and will continue to monitor all systems to ensure a complete resolution.

Resolved

26 August 2025, 21:56 UTC

26 August 2025, 21:56 UTC

This incident has been fully resolved. Between 16:59 UTC and 17:13 UTC, customers experienced elevated errors on our dashboard and data services. A mitigation was deployed at 17:13 UTC, after which the majority of the impact was resolved. Some customers may have experienced subsequent delays in rule propagation for newly configured rules. We have concluded our monitoring and have seen no further recurrences.

To offer feedback on our status page, click "Give Feedback