Retrospective: Impacted Performance API Services, Real-time Analytics

Informational
25 August 2025, 18:15 UTC

Retrospective: Impacted Performance API Services, Real-time Analytics

Status: closed
Date: 25 August 2025, 17:45 UTC
End: 25 August 2025, 18:15 UTC
Duration: 30 minutes
Affected Components:
Fastly Observability Fastly Application Real-time Analytics API & Configuration Management API Services
Affected Groups:
All Public Users
Monitoring

25 August 2025, 17:45 UTC

25 August 2025, 17:45 UTC

Our engineers detected a performance impacting event which affected our Real-Time Analytics and API Services. Customers may have experienced impact  from 17:33 to 17:45 UTC and again from 18:03 to 18:15 UTC.

Our teams have implemented a fix for the event and this incident is resolved.

All other Fastly services were unaffected by this event.

Resolved

25 August 2025, 18:15 UTC

25 August 2025, 18:15 UTC

This event has been resolved.

To offer feedback on our status page, click " Give Feedback "

Status Post, Created Date/Time: 2025-08-25 21:50 UTC