Potential Billing Delays for August 2025 Invoices

Maintenance
28 August 2025, 20:00 UTC

Potential Billing Delays for August 2025 Invoices

Status: closed
Start: 28 August 2025, 16:00 UTC
End: 28 August 2025, 20:00 UTC
Duration: 4 hours
Affected Components:
Fastly Customer Services Billing System General Updates
Affected Groups:
All Public Users
Update

28 August 2025, 16:00 UTC

28 August 2025, 16:00 UTC

Due to the recent implementation of a new billing system, you may experience a delay in receiving your invoice for August 2025. We are committed to prompt and accurate billing and apologize for any inconvenience this may cause. 

What’s next? What do I have to do?

Fastly's support team will contact affected customers with more details during North America business hours on Thursday, 4th of September 2025.

On the 5th of September, if you have not yet received your invoice and have not been contacted by us through the notifications center in the Fastly User Interface (UI), please email us at billing@fastly.com. We will work with you to resolve any issues.

For other questions or concerns, please contact our Support team at https://support.fastly.com or reach out to your designated account team members.

Resolved

28 August 2025, 20:00 UTC

28 August 2025, 20:00 UTC

To offer feedback on our status page, click "Give Feedback