Elevated Errors for Compute and Next-Gen WAF (NGWAF)

Incident
18 August 2025, 22:26 UTC

Elevated Errors for Compute and Next-Gen WAF (NGWAF)

Status: closed
Start: 18 August 2025, 18:50 UTC
End: 18 August 2025, 22:26 UTC
Duration: 3 hours 36 minutes
Affected Components:
Compute Security Fanout Fastly Compute AI Accelerator Edge Cloud Services Websockets Next-Gen WAF (NGWAF) Config Store KV Store Secret Store
Affected Groups:
All Public Users
Investigating

18 August 2025, 18:50 UTC

18 August 2025, 18:50 UTC

We are investigating elevated errors and increased latency to our Compute and Next-Gen WAF (NGWAF) services.

All other products and services are unaffected by this incident.

Identified

18 August 2025, 19:32 UTC

18 August 2025, 19:32 UTC

Our engineers have identified the contributing factor and are developing a fix to our Compute, Next-Gen WAF (NGWAF) service.

All other locations and services are unaffected.

Identified

18 August 2025, 20:19 UTC

18 August 2025, 20:19 UTC

Our engineers have identified the primary cause and we've deployed mitigation steps for the issues impacting Compute and our Next-Gen WAF (NGWAF).

We are aware that our status post updates are not reaching dedicated customer chat channels correctly. For the most current and accurate information, please continue to follow the incident directly on our status page, through SMS or Email notifications which remain unaffected by this incident.

We're continuing to work with our incident response teams to fully restore service. We'll provide another update as soon as more information is available. All other locations and services are unaffected.

Identified

18 August 2025, 21:02 UTC

18 August 2025, 21:02 UTC

We can confirm that Compute services have been restored.

Our teams remain actively engaged in mitigating the issue affecting Next-Gen WAF (NGWAF) services. We'll continue to provide updates as soon as new information is available. 

All other locations and services are unaffected. 

Monitoring

18 August 2025, 22:06 UTC

18 August 2025, 22:06 UTC

We've confirmed that the issues impacting both our Compute and Next-Gen WAF (NGWAF) services have been mitigated. 

We will continue to monitor until we’ve confirmed that customer experience has been fully restored.

Resolved

18 August 2025, 22:26 UTC

18 August 2025, 22:26 UTC

This incident has been resolved. On the 18th of August 2025, customers experienced impact to Compute services between 18:50-19:26 UTC and NGWAF services between 18:50-21:59 UTC. During these times, customers may have seen elevated errors and increased latency. Services leveraging Compute, such as certain public APIs (KV Store, Domainr, etc.), were also affected.

Separately, our CX Escalation engineers identified and resolved a vendor-related issue that prevented status updates from reaching dedicated customer chat channels during a portion of the incident. All notification systems are now fully operational.

This incident is fully resolved.

To offer feedback on our status page, click " Give Feedback

Status Post, Created Date/Time: 2025-08-18 19:09:15 UTC



Note:  Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.