New Data Centers in Madurai (IXM) and Delhi (QAG

Maintenance
19 August 2025, 22:00 UTC

New Data Centers in Madurai (IXM) and Delhi (QAG

Status: closed
Start: 19 August 2025, 18:00 UTC
End: 19 August 2025, 22:00 UTC
Duration: 4 hours
Affected Components:
Fastly Platform Customer Services Asia General Updates Delhi (QAG) Madurai (IXM)
Affected Groups:
All Public Users
Update

19 August 2025, 18:00 UTC

19 August 2025, 18:00 UTC

As part of Fastly's ongoing global network expansion, we are announcing the addition of our new data centers in Madurai (IXM) and Delhi (QAG).

These facilities will initially launch as a limited availability deployment on the 19th of August, 2025, meaning not all customer traffic will be routed through this new location during this initial phase.

Our estimated duration is 4 hours, starting at 18:00 UTC on Aug-19th. 

When this change is applied, customers may observe additional origin traffic as new cache nodes retrieve content from origin. Please verify that your origin access lists allow the full range of Fastly IP addresses [Public IP List | Fastly Documentation]. 

Customers with any questions or concerns may engage with our Support team through [Fastly Support] or by contacting your designated account management team members.

Resolved

19 August 2025, 22:00 UTC

19 August 2025, 22:00 UTC

The scheduled maintenance has been completed.

To offer feedback on our status page, click "Give Feedback"