Retrospective: Impacted Performance in Frankfurt (FRA), Munich (MUC)

Informational
30 July 2025, 12:48 UTC

Retrospective: Impacted Performance in Frankfurt (FRA), Munich (MUC)

Status: closed
Date: 30 July 2025, 12:36 UTC
End: 30 July 2025, 12:48 UTC
Duration: 12 minutes
Affected Components:
Platform Europe Frankfurt (FRA) Munich (MUC)
Affected Groups:
All Public Users
Monitoring

30 July 2025, 12:36 UTC

30 July 2025, 12:36 UTC

Fastly engineers identified and resolved an unusual traffic event affecting our Munich (MUC) and Frankfurt (FRA) Points of Presence (POPs).

From 12:36 to 12:48 UTC (approximately 12 minutes), customers using compute services within the MUC and FRA POPs may have experienced elevated 503 error responses and increased latency during the impact window.

Our engineers responded with standard incident response best practices, and all impacted compute services should now be fully restored for our customers.

Resolved

30 July 2025, 12:48 UTC

30 July 2025, 12:48 UTC

This incident is resolved.

Affected customers may have experienced impact to varying degrees and to a shorter duration than as set forth above.

To offer feedback on our status page, click "Give Feedback"