Elevated Errors for Fastly Application

Incident
11 July 2025, 22:47 UTC

Elevated Errors for Fastly Application

Status: closed
Start: 11 July 2025, 21:51 UTC
End: 11 July 2025, 22:47 UTC
Duration: 56 minutes
Affected Components:
Fastly Security Security Console & API Fastly Application API & Configuration Management Data Services Dashboard Data Notification Center Rate Limiting and Alerts Requests Signals Dashboard API Services Configuration Management Services
Affected Groups:
All Public Users
Investigating

11 July 2025, 21:51 UTC

11 July 2025, 21:51 UTC

We are investigating elevated errors to our Fastly Application services. Customers may experience an error when attempting to access their Fastly Control Panel.

Our ability to serve Network and Security services are not affected by this event.

Update

11 July 2025, 22:16 UTC

11 July 2025, 22:16 UTC

We continue to investigate this event as a high priority, responding engineers have confirmed that the Security Console & API is also impacted. Customers attempting to access their Signal Sciences Dashboards will experience an error when attempting to log in.

Monitoring

11 July 2025, 22:32 UTC

11 July 2025, 22:32 UTC

Engineering has confirmed the impact to our Fastly Application and Security Console & API  has been mitigated. Customers who were logged in at the onset of this incident may be required to log back in order to obtain access.

Our ability to deliver existing Network and Security services to our customers was not affected by this incident. Full duration of possible impact will be provided in our final update. Engineers and acute incident response teams are monitoring to ensure no further impact.

Resolved

11 July 2025, 22:47 UTC

11 July 2025, 22:47 UTC

Engineering has confirmed that both the Fastly Application and Security Console have been fully restored. Customers may have experienced an error when attempting to access these systems and their control panels from 21:51 to 22:12 UTC.

Our engineers did confirm with acute incident responders that api.fastly.com was not affected by this incident.

This incident is resolved.

To offer feedback on our status page, click "Give Feedback

Status Post, Created Date/Time: 2025-07-11 22:08:11 UTC 



Note: Our Customer Escalation Management team have updated the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.