Updates to User Management options in the Fastly Application
Updates to User Management options in the Fastly Application
09 July 2025, 18:13 UTC
09 July 2025, 18:13 UTC
On the 9th of July 2025, Fastly released an update to introduce Automated User Lifecycle Management. This update included provisioning, deprovisioning, and real-time updates via System for Cross-domain Identity Management (SCIM) which are now available via the Fastly Control Panel for all Fastly services for customers using Okta.
What’s Changing?
This update will enable:
- Reduction in Human Errors: Reduction in overhead associated with manually managing users within the applications.
- Automated User Management: SCIM integration improves security by ensuring that user management is restricted to and inherited from the Identity Provider (IdP), reducing the risk of manual errors.
- Comprehensive Audit Logs: Detailed logging of all SCIM-related activities supports compliance requirements for user activity monitoring and reporting.
- Reduced Manual Intervention: Automating user provisioning and deprovisioning minimizes the risk of human error in account management
- Improved Security Posture: Improve security posture for Fastly and you, by ensuring all user management is restricted/inherited from an IdP.
- SCIM 2.0 Compatibility: Adherence to SCIM 2.0 specifications ensures interoperability and compliance with industry standards for identity management.
To learn more about why we have made this change please read our Automating user management documentation.
What’s next? What do I have to do?
Nothing. All actions taken during this planned release belong to Fastly.
Contact Information
Customers with any questions or concerns may engage with our Security team through security@fastly.com or by contacting our Support team at https://support.fastly.com.
09 July 2025, 22:13 UTC
09 July 2025, 22:13 UTC
This event has been resolved.
To offer feedback on our status page, click "Give Feedback"
Status Post, Created Date/Time: 0001-01-01 00:00:00 UTC
Note: Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.