Updates to User Management options in the Fastly Application

Maintenance
03 June 2025, 20:00 UTC

Updates to User Management options in the Fastly Application

Status: closed
Start: 03 June 2025, 16:00 UTC
End: 03 June 2025, 20:00 UTC
Duration: 4 hours
Affected Components:
Fastly Fastly Application API & Configuration Management Notification Center API Services Configuration Management Services
Affected Groups:
All Public Users
Update

03 June 2025, 16:00 UTC

03 June 2025, 16:00 UTC

On the 30th of June 2025 at 19:00 UTC, Fastly will release new options for fine-tuned control over user access and permissions within the Fastly Control Panel. This release is a part of our continued effort to optimize the efficiency and effectiveness of our platform.

What’s Changing?

This update introduces two enhancements to help you manage user access and Transport Layer Security (TLS) related permissions more effectively:

  • New user roles:

    • We've added TLS Viewer and TLS Admin roles to give you more granular control over TLS configurations.

    • These roles allow you to assign TLS-specific access without granting broader platform permissions.

  • Improved roles visibility in the UI:

    • The Active Users view in the User Management UI now includes a Role column, making it easier to see and audit what roles are assigned to each user.

Both new TLS user roles will be available on the 30th of June 2025 for adding a new user account or configuring user roles and permissions for current users accounts. 

What’s next? What do I have to do?

Nothing. Our engineers have prepared upcoming maintenance to our Fastly Application, and there is no anticipated action or impact for our customers. Customers will have additional options to customize their new and existing user permissions. Rest assured that Fastly is not updating any existing permissions as a result of this maintenance. Customers may review and adjust their own preferences at their own pace.

Customers with any questions or concerns may engage with our Support team through https://support.fastly.com.

Resolved

03 June 2025, 20:00 UTC

03 June 2025, 20:00 UTC

On the day of the release a subsequent post will be shared as an announcement, and will include a link to updated material on our docs.fastly.com webpage.


To offer feedback on our status page, click "Give Feedback"