Retrospective: Impacted Performance in API Services

Informational
06 May 2025, 16:22 UTC

Retrospective: Impacted Performance in API Services

Status: closed
Date: 06 May 2025, 14:17 UTC
End: 06 May 2025, 16:22 UTC
Duration: 2 hours 5 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management API Services
Affected Groups:
All Public Users
Monitoring

06 May 2025, 14:17 UTC

06 May 2025, 14:17 UTC

Fastly Engineers have confirmed a performance impacting event that affected the API Services. Customers may have experienced a 410 error code with a plan to apply changes to services in Terraform from 14:17 to 16:22 UTC.

All other services were unaffected. The issue has been resolved and we are monitoring performance closely.

Resolved

06 May 2025, 16:22 UTC

06 May 2025, 16:22 UTC

This incident has been resolved.

To offer feedback on our status page, click "Give Feedback