API Services with Possible Impact

Incident
03 May 2025, 17:45 UTC

API Services with Possible Impact

Status: closed
Start: 02 May 2025, 22:41 UTC
End: 03 May 2025, 17:45 UTC
Duration: 19 hours 4 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management API Services
Affected Groups:
All Public Users
Investigating

02 May 2025, 22:41 UTC

02 May 2025, 22:41 UTC

We're investigating possible performance impact affecting our API Services.

Update

02 May 2025, 23:30 UTC

02 May 2025, 23:30 UTC

Our engineers are continuing to investigate impact to our API Services.

Resolved

03 May 2025, 17:45 UTC

03 May 2025, 17:45 UTC

Our Engineering team will continue to research a possible error which occurs for Fastly customers attempting to create their very first ACL for their Compute service. 

Early investigative results show no errors for existing ACLs, or the ability to create new ones for those customers who have created one in the past.

Our ability to delivery Network and Security services is not affected by this event. For more information please reach out to Support team at https://support.fastly.com/ All additional updates will be shared via standard support practices and directly with any impacted customers. 

To offer feedback on our status page, click "Give Feedback