Update to Fastly’s Billing Experience within our Fastly Application

Informational
05 May 2025, 23:59 UTC

Update to Fastly’s Billing Experience within our Fastly Application

Status: closed
Date: 29 April 2025, 17:59 UTC
End: 05 May 2025, 23:59 UTC
Duration: 6 days 6 hours
Affected Components:
Fastly Fastly Application API & Configuration Management Notification Center API Services Configuration Management Services
Affected Groups:
All Public Users
Update

29 April 2025, 17:59 UTC

29 April 2025, 17:59 UTC

From Monday, April 21st through Wednesday, April 28th, 2025, Fastly shared a status post about a series of updates performed to enhance the billing platform within the Fastly Control Panel. 

To ensure the accuracy of invoices billed for the month of April 2025, our billing team will enter a period of manual review and validation beginning on the 1st of May, 2025 through the 5th of May, 2025. As a result, some customers may experience a delay when receiving their invoices.

What’s next? What do I have to do?

If you receive your invoice and identify a discrepancy, please reach out to billing@fastly.com and we will work with you to resolve the issue.

Customers with any questions or concerns may engage with our Support team through https://support.fastly.com or by contacting your designated account management team members.

Resolved

05 May 2025, 23:59 UTC

05 May 2025, 23:59 UTC

This event has been resolved.

To offer feedback on our status page, click "Give Feedback" 

Status Post, Created Date/Time: 0001-01-01 00:00:00 UTC 



Note: Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.