Update to Fastly Account Password Requirements

Maintenance upcoming 30 minutes
19 May 2025, 14:00 UTC

Update to Fastly Account Password Requirements

Status: upcoming
Start: 19 May 2025, 14:00 UTC
Estimated Duration: 30 minutes
Affected Components:
Fastly Fastly Application API & Configuration Management Notification Center API Services Configuration Management Services
Affected Groups:
All Public Users
Update

19 May 2025, 14:00 UTC

19 May 2025, 14:00 UTC

As part of our ongoing commitment to account security and alignment with industry standard best practices, we’re strengthening our password policy across our Fastly Application and Next-Gen WAF (NGWAF) Console product offerings.

Fastly will be performing maintenance on the Fastly Control Panel on the 19th of May 2025 from 14:00 to 14:30 UTC (~30 minute duration).

What’s Changing?

Beginning on the 19th of May 2025, any user who creates a new account or resets their password in the Fastly Application will be required to choose a password that is at least 12 characters long including letters, numbers, and special characters. This change will affect the Sign Up, Create Account, and Reset Password experiences on our website. 

This change will help maintain account security and provides significant benefits to our users, including: 

  • Longer passwords are more secure and significantly reduce the risk of brute‑force or guessing attacks
  • A minimum length of 12 characters meets the current recommended industry security standard
  • Safeguards your data against unauthorized access and protects user accounts

This new password requirement condition will be displayed in real time as a password is entered into any password field on the website. Users attempting to submit a password with fewer than 12 characters, including Application Programming Interface (API) or Terraform requests to Create or Reset a password, will fail.

This change will not impact existing account passwords and will only apply to new account passwords or when a password reset is requested.

What’s next? What do I have to do?

If you have an integration using our Fastly API or Terraform modules to automate account creation or password resets, you’ll need to update your code and configurations to enforce the new 12 character minimum requirement.

Remember that all passwords associated with your Fastly account are case sensitive.

Your account will continue to operate as expected and all other products and services remain unaffected by this maintenance.

Contact Information

Customers with any questions or concerns may engage with our Support team through https://support.fastly.com or by contacting your designated account management team members.