Update to Fastly’s Billing Experience within our Fastly Application
Update to Fastly’s Billing Experience within our Fastly Application
21 April 2025, 12:23 UTC
21 April 2025, 12:23 UTC
From Monday, April 21 through Thursday, April 24, 2025, Fastly will be performing a series of updates to enhance the billing platform within the Fastly Control Panel.
During this effort customers may not be able to retrieve the latest month-to-date billing information. You may contact the Fastly Support team at support@fastly.com for assistance if this error is encountered.
The ability to access your Fastly Control Panel, update configurations, and leverage our API services will not be impacted as a result of these updates.
What’s next? What do I have to do?
Nothing. During the updates, no immediate actions are required by customers. However, certain observable impacts or changes should be noted in advance of the update implementation, these will include:
The Month-to-Date (MTD) billing page may experience temporary unavailability, potentially lasting up to 48 hours.
The ‘Pay Now’ functionality will be removed from the Invoices page and will instead be available in future invoice PDF documents.
Customers with any questions or concerns may engage with our Support team through at https://support.fastly.com or by contacting your designated account management team members.
24 April 2025, 22:18 UTC
24 April 2025, 22:18 UTC
This maintenance has been extended to Monday, April 28th 2025.
28 April 2025, 23:30 UTC
28 April 2025, 23:30 UTC
The scheduled maintenance has been completed.
To offer feedback on our status page, click
"
Give Feedback
"