Elevated Errors for Amsterdam (RTM) *and London (LCY) Data Centers

Incident
16 April 2025, 21:27 UTC

Elevated Errors for Amsterdam (RTM) *and London (LCY) Data Centers

Status: closed
Start: 16 April 2025, 19:27 UTC
End: 16 April 2025, 21:27 UTC
Duration: 2 hours
Affected Components:
Platform Europe Amsterdam (RTM) London (LCY)
Affected Groups:
All Public Users
Investigating

16 April 2025, 19:27 UTC

16 April 2025, 19:27 UTC

We are investigating elevated errors to our Amsterdam (RTM) Point of Presence (POP).

Identified

16 April 2025, 20:25 UTC

16 April 2025, 20:25 UTC

Our engineers have identified the contributing factor and are applying a fix to our Amsterdam (RTM) POP.

All other locations and services are unaffected.

Monitoring

16 April 2025, 20:26 UTC

16 April 2025, 20:26 UTC

Engineering has confirmed the impact to Amsterdam (RTM) (POP) has been mitigated.

Resolved

16 April 2025, 21:27 UTC

16 April 2025, 21:27 UTC

Engineering has confirmed that Amsterdam (RTM) (POP) has been fully restored. Customers may have experienced elevated errors and latency  from 19:27 to 20:44  UTC.

This incident is resolved.

To offer feedback on our status page, click " Give Feedback

Status Post, Created Date/Time: 2025-04-16 20:18:45 UTC

Update added by Escalation Management on 16th of April 2025

Retrospective investigations have identified similar degraded performance to Compute Services within the LCY POP as a result of this incident. This information has been added to ensure data accuracy and transparency for affected customers.



Note:  Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.