Support Portal Re-Design Update

Maintenance
14 April 2025, 21:00 UTC

Support Portal Re-Design Update

Status: closed
Start: 14 April 2025, 19:00 UTC
End: 14 April 2025, 21:00 UTC
Duration: 2 hours
Affected Components:
Fastly Customer Services Support Systems https://support.fastly.com Chatbot Feature New Support Case
Affected Groups:
All Public Users
Update

14 April 2025, 19:00 UTC

14 April 2025, 19:00 UTC

The Fastly Support Portal (https://support.fastly.com/s/) will be relaunched for Support-package customers on the 14th of April 2025 at 21:00 UTC.

The maintenance window will be from 19:00 - 21:00 UTC on the 14th of April 2025, during which customers may experience temporary errors when attempting to access the re-designed Fastly Support Portal.

We will share the release plan for non-Support Package customers at a later date. Until then, these customers can contact Support via email at support@fastly.com or visit our Community page (https://community.fastly.com/) for answers to common questions and the latest updates.

Support Chat and Support Email best practices will remain unaffected by this maintenance activity, and we do not anticipate any negative impact to our service level agreements (SLAs) related to support response times by our support engineers.

Resolved

14 April 2025, 21:00 UTC

14 April 2025, 21:00 UTC

The scheduled maintenance has been completed.

To offer feedback on our status page, click "Give Feedback