Next-Gen WAF (NGWAF) with Possible Impact

Incident
09 April 2025, 01:25 UTC

Next-Gen WAF (NGWAF) with Possible Impact

Status: closed
Start: 08 April 2025, 20:03 UTC
End: 09 April 2025, 01:25 UTC
Duration: 5 hours 22 minutes
Affected Components:
Security Next-Gen WAF (NGWAF)
Affected Groups:
All Public Users
Investigating

08 April 2025, 20:03 UTC

08 April 2025, 20:03 UTC

We're investigating possible performance impact affecting the Next-Gen WAF (NGWAF) service.

Identified

08 April 2025, 21:29 UTC

08 April 2025, 21:29 UTC

Our engineers have identified the contributing factor and are applying a fix to our Next-Gen WAF (NGWAF) services.

Identified

08 April 2025, 22:24 UTC

08 April 2025, 22:24 UTC

Our engineers have identified the potential contributing factor and are continuing to apply the mitigation strategy to our Next-Gen WAF (NGWAF) service.

Monitoring

08 April 2025, 23:14 UTC

08 April 2025, 23:14 UTC

A correction has been deployed to the NGWAF platform by Engineering, resulting in a phased recovery for affected customers. Deployment monitoring will persist until full service restoration is observed for all impacted services.

This incident caused disruption to customers utilizing NGWAF services; all other products and services remained operational.

Customers experiencing ongoing issues are encouraged to contact their assigned account teams or the support team through dedicated support chat or email at support@fastly.com if a case is not already in progress.

Resolved

09 April 2025, 01:25 UTC

09 April 2025, 01:25 UTC

Engineering has confirmed that our Next-Gen WAF (NGWAF) service has been fully restored. Customers utilizing Next-Gen WAF (NGWAF) services may have experienced elevated 5xx and 4xx errors from the 8th of April at 20:03 to the 9th of April at 01:07 UTC.

This incident is resolved.

Affected customers may have experienced impact to varying degrees and to a shorter duration than as set forth above.

To offer feedback on our status page, click "Give Feedback

Status Post, Created Date/Time: 2025-04-08 20:50:17 UTC 



Note: Our Customer Escalation Management team will update the start date and time of the initial "investigating" status post upon the resolution of this incident. This update is meant to provide our customers and their end users with a potential impact window. The date and time mentioned in the message above indicates when the status post was requested by our Acute Incident Response team.